Please note that Sahi's development and support teams do not actively monitor this. This is more a community forum. If you are a Sahi Pro user looking for commercial support, please email support @ sahipro.com with your query.

Xstudio launching sahi, not working

chrisb123chrisb123 Members
edited September 2015 in Sahi - Open Source
I am trying to launch sahi scripts from xstudio
From the directory D :\sahi\userdata\bin
I run the commands manually, first start the rpoxy
"C :/Program Files/Java/jdk1.8.0_51/bin/java.exe" -cp ../../lib/sahi.jar;../../extlib/rhino/js.jar;../../extlib/apc/commons-codec-1.3.jar net.sf.sahi.Proxy ../.. ..
Then in another terminal I run
D :/sahi/tools/toggle_IE_proxy.exe disable
then
"C :/Program Files/Java/jdk1.8.0_51/bin/java.exe" -cp ../../lib/ant-sahi.jar net.sf.sahi.test.TestRunner -test "D :/sahi/userdata/scripts/test.sah" -browserType "C:/Program Files/Internet Explorer/IEXPLORE.EXE" -baseURL http://10.45.136.205 -host localhost 9999 -threads 3 iexplore.exe "-noframemerging"

Nothing happens and I get this on the proxy terminal

Sep 24, 2015 1:14:52 PM net.sf.sahi.command.CommandExecuter execute
WARNING: commandClass = >net.sf.sahi.command.Suite< commandMethod = >start<
Sep 24, 2015 1:14:52 PM net.sf.sahi.command.CommandExecuter execute
WARNING: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at net.sf.sahi.command.CommandExecuter.execute(CommandExecuter.java:55)
at net.sf.sahi.LocalRequestProcessor.handleDyn(LocalRequestProcessor.java:67)
at net.sf.sahi.LocalRequestProcessor.getLocalResponse(LocalRequestProcessor.java:40)
at net.sf.sahi.ProxyProcessor.processLocally(ProxyProcessor.java:209)
at net.sf.sahi.ProxyProcessor.run(ProxyProcessor.java:86)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
at net.sf.sahi.command.Suite.getPreconfiguredBrowserSuite(Suite.java:97)
at net.sf.sahi.command.Suite.getSuite(Suite.java:73)
at net.sf.sahi.command.Suite.start(Suite.java:60)
... 12 more
Sign In or Register to comment.